We gratefully acknowledge support from
the Simons Foundation and member institutions.
Full-text links:

Download:

Current browse context:

econ

Change to browse by:

References & Citations

Bookmark

(what is this?)
CiteULike logo BibSonomy logo Mendeley logo del.icio.us logo Digg logo Reddit logo

Economics > Econometrics

Title: require: Package dependencies for reproducible research

Abstract: The ability to conduct reproducible research in Stata is often limited by the lack of version control for user-submitted packages. This article introduces the require command, a tool designed to ensure Stata package dependencies are compatible across users and computer systems. Given a list of Stata packages, require verifies that each package is installed, checks for a minimum or exact version or package release date, and optionally installs the package if prompted by the researcher.
Comments: for associated Git repo, see this https URL
Subjects: Econometrics (econ.EM)
Cite as: arXiv:2309.11058 [econ.EM]
  (or arXiv:2309.11058v1 [econ.EM] for this version)

Submission history

From: Sergio Correia [view email]
[v1] Wed, 20 Sep 2023 04:35:07 GMT (98kb,D)

Link back to: arXiv, form interface, contact.